(C) 2012 - 2020 by Mourad Louha · All rights reserved.
Privacy  ·  Imprint

Translator

The Microsoft Excel functions have been localized into many languages. If you send your Excel file to someone using a different language for Excel than you, the functions and formulas used in the workbook are automatically translated by Excel when opening the file. However, the automatic translation usually does not work, if you directly insert foreign language formulas into your worksheet. Such a situation may for example occur, if you are using Excel in German and want to use an English formula provided by a forum. The following online tool allows you to translate an Excel formula from one language into another language and therefore use the localized formula.

Microsoft ExcelMore information

Select your Microsoft Excel version. If you are using an Excel version older than Excel 2010, then select the last entry in the list. Please note, that some Excel function names have been translated differently across different Excel versions. This is for example the case for the function VLOOKUP. The Dutch translation for the function VLOOKUP is OPZOEKEN for Excel 2010 and ZOEKEN for Excel 2010 SP1 and above.

Source formulaMore information

Please enter either a single Excel function or a formula to the source formula field. If you enter a formula, the formula should have a correct syntax. The translator translates the function names, error values such as #DIV/0! and optionally the arguments for the CELL and INFO function.

Source languageMore information

Select the source language. The language must match the language of the function or formula previously entered, so that the translator can recognize the names.

Target languageMore information

Select the target language. Please note, that for several languages not all functions have been localized. There are even languages where only the arguments for the CELL and INFO functions have been translated.

OptionsMore information

The first option allows you to specify if the argument separators should be replaced. This is for example important, if you are translating an English formula to German. Usually, the comma is used as argument separator in an English Excel version and the semi-colon in a German Excel version. Therefore, you need to replace the argument separator, so that the German Excel version recognizes the formula. The Excel-Translator automatically suggests you an option when selecting a language. The other options allow you to specify whether the first arguments for the CELL and INFO function should be translated to English or to the target language. These options are set to the English translation by default, as Excel always recognizes the arguments in English.

Separator for the function arguments

First argument for CELL()

First argument for INFO()

Target formula

 
 
Comments

Hi Nabil,
thank you very much :-)
Regarding Arabic, no translation has been done for the Excel functions, error codes, arguments and table specifiers. So, all is in English. MS only translated the User Interface for Excel.
Best, Mourad

That’s an amazing tool and a very useful addition to Excel. I have been asked on my YouTube channel about names of functions in French, Portuguese … and could not help…
looking forward to Arabic as well…
You deserve a Nobel Prize for this achievement

Hello,
thank you for the note. In Excel 2010 before Service Pack 1, the function SEARCH was translated as PESQUISAR. Since Excel 2010 SP1, the translation is LOCALIZAR.
Did you select in the online tool Excel 2010? If so, then I guess, you already have Service Pack 1 or a higher Excel version. Please then select at least Excel 2010 SP1.
Best,Mourad

Function SEARCH in Portuguese-Brazilian should be LOCALIZAR and not PESQUISAR.

Hi Alfredo,
my Online Tool does not take into account the (very) old Excel functions. Below the translations of the old function FILES, I am aware of. So, your translation seems to be correct.

Language, Code, Function

English (United States), en-US, FILES
Catalan (Spain), ca-ES, ARCHIVOS
Chinese (Hong Kong SAR, PRC), zh-HK, FILES
Chinese (Taiwan), zh-TW, FILES
Czech (Czech Republic), cs-CZ, SOUBORY
Danish (Denmark), da-DK, FILER
Dutch (Netherlands), nl-NL, BESTANDEN
Finnish (Finland), fi-FI, TIEDOSTOT
French (France), fr-FR, FICHIERS
German (Germany), de-DE, DATEIEN
Hungarian (Hungary), hu-HU, FILELISTA
Italian (Italy), it-IT, FILE.IN.DIRECTORY
Japanese (Japan), ja-JP, FILES
Norwegian (Bokmål, Norway), nb-NO, FILER
Polish (Poland), pl-PL, PLIKI
Portuguese (Brazil), pt-BR, ARQUIVOS
Portuguese (Portugal), pt-PT, FICHEIROS
Russian (Russia), ru-RU, ФАЙЛЫ
Spanish (Spain), es-ES, ARCHIVOS
Swedish (Sweden), sv-SE, FILER
Turkish (Turkey), tr-TR, DOSYALAR

If it does not work, I can not tell you exactly why, but maybe Excel is disabling those functions, e.g. through its File Block Settings from the Trusted Center Options. However, I did not test that.

Best,
Mourad

Hello,
I’m trying to translate the old FILES() Excel function into Spanish, but have not been able to. I have tried “ARCHIVOS()”, “ARCHIVO()” and “FILES()”, but neither of them work. Could you please help me? Thank you!

Hi JMJ,

thank you very much :-)

And thank you for pointing me to the problem with the translation of array formulas.

I am aware of this, but I did not find a reliable solution yet, as this is a bit more complex. This as the array separators are depending from the Excel language and the operating system language. Yes, I could use defaults for the OS language, but then it will also depend from in which language Excel is installed. Excel then chooses a dot, a comma or a backslash as array separators. The logic behind this is not fully clear for me, despite some larger tests.

Best,
Mourad

Hi! I love your tool and use it rather often. I just wanted to draw your attention on a problem I just encountered while translating a formula from English to French.
The original formula: =VLOOKUP(C9,CHOOSE({1,2},D3:D7,C3:C7),2,TRUE)
The proposed translation: =RECHERCHEV(C9;CHOISIR({1;2};D3:D7;C3:C7);2;VRAI)
The GOOD translation: =RECHERCHEV(C9;CHOISIR({1.2};D3:D7;C3:C7);2;VRAI)
Note the DOT used as a separator in the curly braces: It’s the only one that works. Any other (,;:) wreaks havoc in the formula.
Thanks for your good job anyway!

Leave a Reply